Announcement

Collapse
No announcement yet.

Maxi Cure Single Phase 36 belt

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maxi Cure Single Phase 36 belt

    Hello,
    MODEL# MC 36-6-1
    Serial#069013165m
    I have an older Maxi Cure with 3 Panels, the first one is heating up at whichever temp I set it too. the 2nd and 3rd
    Panels are not indicating they are on. When using a temp gun they show 250 on 2nd one and 3rd one at end of dryer is showing 150. Am I looking at bad panels ? bad thermacoupler ? . Is there a way to trouble shoot with meter to determine what parts need replacing? Thank you for your time

  • #2
    Re: Maxi Cure Single Phase 36 belt

    I'm guessing they're just absorbing heat from the first panel, and not on. If the other panels are getting power up to where it connects to heater coils, and no heat, the panels are dead. If no power, probably a fuse or a solid-state switch or a thermocouple... just guessing, I haven't had an electric dryer for many years.

    Comment


    • #3
      Re: Maxi Cure Single Phase 36 belt

      I Have 248V across Mercury Switches On top and bottom of them . From there I would think it goes straight to the panels. Maybe bad panels then? Thanks John Drake for reading and replying

      Comment


      • #4
        Re: Maxi Cure Single Phase 36 belt

        You need to test where wires connect to the panel. Could be burned up there or inside the panel. Check intekcorp.com. They make heater panels and you may be able to buy the heating element only and reuse the housing to save money. I've done that with my infrared flashes.

        Comment


        • #5
          Re: Maxi Cure Single Phase 36 belt

          Originally posted by John Drake View Post
          You need to test where wires connect to the panel. Could be burned up there or inside the panel. Check intekcorp.com. They make heater panels and you may be able to buy the heating element only and reuse the housing to save money. I've done that with my infrared flashes.

          Thanks!! I pulled the top cover off and fixed 1 lead on 2 of the 3 panels. dryer worked great all day.

          Comment

          Working...
          X